OnCourse Software

Page 1 of 1

Author:  Vonhessler [ Mon Mar 22, 2021 12:17 pm ]

Hello everyone.

There is a problem selecting MSFS flight plan: PF3 find a problem processing the flight plan (in PLN format), report "RUN TIME ERROR 9: SUBSCRIPT OUT OF RANGE" and crash.

PF3 has been reinstaled and updated, and database has been rebuilted.

Any ideas?


Author:  dmarch [ Mon Mar 22, 2021 12:43 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

I moved this post from the PFE forum as I'm assuming you're runing PF3 because PFE does notwork with that sim.

There's nothing whatsoever wrong with PF3 loading MSFS flight plans as I and many others do it on a daily basis, so I suspect it is a system related issue. However you haven't given me anything to look at so will find it hard to give a definitive answer I'm afraid.

Please zip and attach the flight plan you're having problems with and also confirm the PF3 version you are using.

Author:  Vonhessler [ Sat Mar 27, 2021 12:19 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

Hi Dave.

Thank you very much for your response.

The problem is with all FP included in the file attached.

PF3 version: 3.10.25 updated 27/03/21 (running as administrator). Installed in drive D.
Sim: MSFS 2020 installed in drive C. (C and D are on different hard disks).

OS: Windows 10 Pro - 64-bit, version 20H2, Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz 2.70 GHz, 16 Gb RAM, NVIDIA GFORCE GTX 1650.

OS and drivers updated. No antivirus.

Used last MakeRwys program and database has been rebuilt on PF3.

Best regards,

FP.zip [9.43 KiB]
Downloaded 41 times

Author:  m_j_lyons [ Sat Mar 27, 2021 12:58 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

Good morning - I had the exact same problem after my first installation. I did a PF3 uninstall and full reinstall. After the second install it asked me to reboot my computer - which I did. After that it worked. Give it a shot - won't cost you more than an hour of your time.

Author:  dmarch [ Sat Mar 27, 2021 1:22 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

First thing to try is running the PF3_Register.exe program from your main PF3 folder. Right-click on it and select 'Run as Administrator'... you won't see anything happen but if you wait about 15 seconds then try the flight plan again.

If that doesn't help please download the Microsoft DirectX for Managed Code Runtimes, using the following link:-

http://www.ocs-support.co.uk/downloads/ ... ntimes.zip

Once downloaded you need to unzip the content into a temporary folder anywhere on your system, then run the downloaded EXE. You will be prompted for a location to copy the extracted files into, so just choose the same temp folder.

Once that's done go into the temp folder and right-click the 'DXSetup.exe' program and then select 'Run as Administrator'

This will NOT alter any of your currently installed DirectX files but merely installs any missing runtimes in parallel
Once the DirectX Runtimes are installed please try running PF3 again and connecting to FS and let me know what happens. You can also delete the downloaded runtimes and temp folder if you wish.

If you still have problems after this then try uninstalling/reinstalling PF3

Author:  Vonhessler [ Tue Mar 30, 2021 2:13 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

Hi Dave, hi Lyons.

I really appreciate your support.

Well, nothing work, so, I decided reinstall OS... and guess what? I forgot deactivate PF3. Sorry.

Dave: can you help me about this matter? Thank you very much.


Author:  dmarch [ Tue Mar 30, 2021 3:33 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM

Please email me direct with your Activation Code

Author:  Vonhessler [ Tue Mar 30, 2021 8:56 pm ]
Post subject:  Re: FLIGHT PLAN PROBLEM


Problem solved. Something was missing in OS. Thank you very much for your kindness.


Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited