OnCourse Software

Welcome to our Product Support Forums
It is currently Thu Jun 17, 2021 9:51 am

All times are UTC+01:00


If you are reporting an issue with PF3 please remember to Zip and attach the Debug_Monitor.log file from your PF3\Logs folder.

Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Tue May 04, 2021 3:28 pm 

Joined: Fri Mar 26, 2021 5:26 pm
Posts: 23
:ugeek: Good morning/afternoon - I finally got my new gaming laptop delivered and moved my MSFS installation and associated programs over - I went through the full registration swap and it worked just fine. Had to install the DirectX Runtimes to get PF3 to connect correctly...solved (interestingly the only way I could find those files was from a download link on your site from post several weeks ago). I rebuilt the database just to be safe...done. Get all my settings the way I like them...and the voice packs worked fine in the menus when selecting my pilot voice. And then load the flight plan - all is good.

When contacting ATC I hear nothing - I then see in CC the radio call out and the FSS response - so PF3 is working - the voices just aren't 'playing' for some reason. Long story short I do the flight and it's all fine. But - I need some help to get the voices going. I'm sure it's something relatively simple. New computer. New installation. What could be wrong. ;)

I validated the installation and it says everything is ok.

Debug_monitor log attached. If you need any others - just yell.

debug_monitor.zip [841.4 KiB]
Downloaded 13 times
PostPosted: Tue May 04, 2021 9:12 pm 

Joined: Fri May 22, 2009 8:27 pm
Posts: 1241
Location: Yorkshire
Haven't looked at your log...but here's a long shot.
1.Right click on Speaker/Headphone icon on your taskbar or in the bottom right hand side is where it should be.
2.Click sounds icon and click on.
3.Click on Communications and change to "Do Nothing"

Also did you run a validation test for all your files when you installed it...(tab on options#2 "Validate your PF3 Installation"

Try this and let us know how you get on.

Regards Dave
Forum Moderator


PostPosted: Tue May 04, 2021 10:27 pm 
Site Admin

Joined: Mon May 18, 2009 6:22 pm
Posts: 4482
I know you say you installed the DirectX files but the log tells me differently so would suggest the following:

Download the Microsoft DirectX for Managed Code Runtimes, using the following link:-

http://www.ocs-support.co.uk/downloads/ ... ntimes.zip

Once downloaded you need to unzip the content into a temporary folder anywhere on your system, then run the downloaded EXE. You will be prompted for a location to copy the extracted files into, so just choose the same temp folder.

Once that's done go into the temp folder and right-click the 'DXSetup.exe' program and then select 'Run as Administrator'

This will NOT alter any of your currently installed DirectX files but merely installs any missing runtimes in parallel
Once the DirectX Runtimes are installed please try running PF3 again and connecting to FS and let me know what happens. You can also delete the downloaded runtimes and temp folder if you wish


Dave March

Email: dmarch@oncourse-software.co.uk

Without a log it didn't happen!


PostPosted: Tue May 04, 2021 11:23 pm 

Joined: Fri Mar 26, 2021 5:26 pm
Posts: 23
Well that fixed it. I know it installed some dot.net update or something along side the DX files this AM...but doing it a second time seemed to have put everything in the proper place. It's working now - thanks.

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 12 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited